انجمن سایت کلیدستان



ایجاد پروژه اندروید در اکلیپس(خیلی فوری 2 ماهه درگیرم)زمان کنونی: ۱۳۹۵/۰۹/۱۳، ۰۲:۵۵ ق.ظ
کاربران در حال بازدید این موضوع: 1 مهمان
نویسنده: faride93
آخرین ارسال: faride93
پاسخ 15
بازدید 714

رتبه موضوع:
  • 0 رای - 0 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
ایجاد پروژه اندروید در اکلیپس(خیلی فوری 2 ماهه درگیرم)

ایجاد پروژه اندروید در اکلیپس(خیلی فوری 2 ماهه درگیرم)

#1
سلام 
من آموزش لیندا را میدیدم چند روزه اینجا را پیدا کردم من همه کارایی که اینجا گفته را برای ایجاد پروژه انجام میدم ولی در قسمتی که در مراحل ایجاد برای ACTIVITY است من قسمت NAVIGATION ندارم و این که مشکلی نیست وقتی پروژه ایجاد میشه 1001 تا ارور داره که من 1 ماه توی همه سایتا گشتم مو به موی کارایی که همه انجام داده بودن انجام دادم ولی باز اون مشکل هست.بخدا کمکم کنید دیگه خسته شدم.
خواهشاااااااااااااااااااا یکی کمکم  کنه این مربوط پایان نامم هست که همین اولش گیر کردم.


فایل‌های پیوست

عکس(ها)
   
پاسخ

ایجاد پروژه اندروید در اکلیپس(خیلی فوری 2 ماهه درگیرم)

#2
منم یاد روزایی افتادم که یک روز نمیشد با ایکلیپس ارورای عجیب غریب نگیرم.

بره همین الان دیگه با اندروید استودیو کار میکنم.
واقعا عالیه و خیلی بهتر از ایکلیپس هستش. گوگل کارش درسته.
پیشنهاد میکنم شما هم همین کارو بکنید.

شاید اولش یکم گیج کننده شاید باشه اما یکم که باهاش روون بشید دیگه واقعا میشه.
پاسخ

ایجاد پروژه اندروید در اکلیپس(خیلی فوری 2 ماهه درگیرم)

#3
و برای مشکلی که دارید با ایکلیپس: تنها کافیه support library رو از android sdk دانلود کنید.

اگر باز هم مشکل حل نشد که به احتمال بالا حل میشه، خبر بدید راهنمایی کنم
پاسخ

ایجاد پروژه اندروید در اکلیپس(خیلی فوری 2 ماهه درگیرم)

#4
داداش باید لایبری ورژن ۷ رو به پروژت اضافه کنی
پاسخ

ایجاد پروژه اندروید در اکلیپس(خیلی فوری 2 ماهه درگیرم)

#5
(۱۳۹۴/۱۲/۲۶, ۰۷:۱۳ ب.ظ)esmail3309 نوشته: و برای مشکلی که دارید با ایکلیپس: تنها کافیه support library رو از android sdk دانلود کنید.

اگر باز هم مشکل حل نشد که به احتمال بالا حل میشه، خبر بدید راهنمایی کنم
ممنون. من اینکارو کرده ام ولی باز ارور داره،یکبار دیگه پروژه ایجاد کردم ولی اروراش بیشتر شد که کمتر نشد Sad(((((((((((((((((((((((
چیکار کنمممممممم؟(چیزایی که توی کنسول نوشته را پیوست کردم )
من با استادیو میخواستم کار نکنم چون همه جا شنیدم کسایی که تازه شروع میکنن بهتره با اکلیپس کار کنن.
من دیگه موندم چیکا کنم خب Sad((((((((((((((((((((((
پاسخ

ایجاد پروژه اندروید در اکلیپس(خیلی فوری 2 ماهه درگیرم)

#6
(۱۳۹۴/۱۲/۲۷, ۱۰:۳۶ ق.ظ)Erfannj نوشته: داداش باید لایبری ورژن ۷ رو به پروژت اضافه کنی

ممنون.قبلا اینکارو کردم نشد. ولی دارم باز اینکارو میکنم ببینم چی میشه!
پاسخ

ایجاد پروژه اندروید در اکلیپس(خیلی فوری 2 ماهه درگیرم)

#7
(۱۳۹۴/۱۲/۲۶, ۰۷:۱۰ ب.ظ)esmail3309 نوشته: منم یاد روزایی افتادم که یک روز نمیشد با ایکلیپس ارورای عجیب غریب نگیرم.

بره همین الان دیگه با اندروید استودیو کار میکنم.
واقعا عالیه و خیلی بهتر از ایکلیپس هستش. گوگل کارش درسته.
پیشنهاد میکنم شما هم همین کارو بکنید.

شاید اولش یکم گیج کننده شاید باشه اما یکم که باهاش روون بشید دیگه واقعا میشه.
هر دفعه که پروژه میسازم یک سری ارور جدید میده!!!! وقتی میگم theme نداشته باشه اروراش کمتر میشه ولی باز ارور داره


فایل‌های پیوست

عکس(ها)
   
پاسخ

ایجاد پروژه اندروید در اکلیپس(خیلی فوری 2 ماهه درگیرم)

#8
پروژه رو اگر میتونید یه جایی آپلود کنید بفرستید ببینم مشکل از کجاست....
پاسخ

ایجاد پروژه اندروید در اکلیپس(خیلی فوری 2 ماهه درگیرم)

#9
در مورد مشکل ابتدایی تون من هم این مشکل رو داشتم و یک هفته ای درگیرش بودم.
ببینید همه پیشنیاز های eclipse باید با هم هماهنگ باشن.
با توجه به ورژن اندرویدی که دانلود کردید مثلا اگه API 14 رو دانلود کردین باید sdk tools و sdk platform-tools و sdk biuld-tools مناسب این ورژه رو دانلود آپدیت کرده باشین. (این رو در sdk manager حتما با دقت چک کنید.)
همچنین با توجه به ورژن API ممکنه نیاز داشته باشین جاوا رو هم اپدیت کنین. مثلا برای API 21 نیاز به دانلود jdk 8 دارید (در 32 یا 64 بیت بودن jdk هم دقت داشته باشید)  این هم یکی از نکات مهمه که اکثرا این نکته باعث ارور می شه.
این مطلب رو هم می تونید در properties پروژه و در زیر شاخه java build path چک کنید اگر در سربرگ libraries اروری مشاهده می کنید مشکل در ورژن جاوا دارید.
مشکل من که بدین ترتیب حل شد. ایشالله مشکل شما هم حل شده باشه.

    

پاسخ
 سپاس شده توسط faride93 ، zanyyy

ایجاد پروژه اندروید در اکلیپس(خیلی فوری 2 ماهه درگیرم)

#10
(۱۳۹۴/۱۲/۲۷, ۰۷:۴۷ ب.ظ)ehtirani نوشته: در مورد مشکل ابتدایی تون من هم این مشکل رو داشتم و یک هفته ای درگیرش بودم.
ببینید همه پیشنیاز های eclipse باید با هم هماهنگ باشن.
با توجه به ورژن اندرویدی که دانلود کردید مثلا اگه API 14 رو دانلود کردین باید sdk tools و sdk platform-tools و sdk biuld-tools مناسب این ورژه رو دانلود آپدیت کرده باشین. (این رو در sdk manager حتما با دقت چک کنید.)
همچنین با توجه به ورژن API ممکنه نیاز داشته باشین جاوا رو هم اپدیت کنین. مثلا برای API 21 نیاز به دانلود jdk 8 دارید (در 32 یا 64 بیت بودن jdk هم دقت داشته باشید)  این هم یکی از نکات مهمه که اکثرا این نکته باعث ارور می شه.
این مطلب رو هم می تونید در properties پروژه و در زیر شاخه java build path چک کنید اگر در سربرگ libraries اروری مشاهده می کنید مشکل در ورژن جاوا دارید.
مشکل من که بدین ترتیب حل شد. ایشالله مشکل شما هم حل شده باشه.

اتفاقا یکی اروراش به andriod dependencies هست ولی من jdk رو گشتم( نمیدونم آخر jre و گیر اوردم یا Jdk)نصب کردم ولی درست نشد.


فایل‌های پیوست

دانلود project.zip

نام فایل project.zip
نوع فایل .zip
دفعات دانلود 9
اندازه 3.45 MB
ارسال کننده فایل faride93
پاسخ

ایجاد پروژه اندروید در اکلیپس(خیلی فوری 2 ماهه درگیرم)

#11
(۱۳۹۴/۱۲/۲۷, ۰۵:۳۹ ب.ظ)esmail3309 نوشته: پروژه رو اگر میتونید یه جایی آپلود کنید بفرستید ببینم مشکل از کجاست....


فایل‌های پیوست

دانلود project.zip

نام فایل project.zip
نوع فایل .zip
دفعات دانلود 19
اندازه 3.45 MB
ارسال کننده فایل faride93
پاسخ

ایجاد پروژه اندروید در اکلیپس(خیلی فوری 2 ماهه درگیرم)

#12
سلام.
جناب،شما برای چه ورژنی از سیستم عامل برنامه ات رو میسازی؟
پاسخ

ایجاد پروژه اندروید در اکلیپس(خیلی فوری 2 ماهه درگیرم)

#13
Wink 
سلام
دوست عزیز این کد رو در منیفست اضافه کن احتمالا درصد عظیمی از مشکلاتت حل بشه.(فاصله کم min sdk و target sdk)
اصلا بهتره موقع ساخت پروژه جدید این مقادیر رو  19 و 21 ست کنی البته در صورت نصب بودن 21.

کد:
<uses-sdk android:minSdkVersion="19" android:targetSdkVersion="21" />


   


دوست عزیز sdk manager رو هم چک کردی که ایشالله همه ی موارد مورد نظر نصب شده باشه؟


پاسخ
 سپاس شده توسط zanyyy

ایجاد پروژه اندروید در اکلیپس(خیلی فوری 2 ماهه درگیرم)

#14
(۱۳۹۴/۱۲/۲۸, ۰۷:۴۱ ب.ظ)ehtirani نوشته: سلام
دوست عزیز این کد رو در منیفست اضافه کن احتمالا درصد عظیمی از مشکلاتت حل بشه.(فاصله کم min sdk و target sdk)
اصلا بهتره موقع ساخت پروژه جدید این مقادیر رو  19 و 21 ست کنی البته در صورت نصب بودن 21.

کد:
<uses-sdk android:minSdkVersion="19" android:targetSdkVersion="21" />


دوست عزیز sdk manager رو هم چک کردی که ایشالله همه ی موارد مورد نظر نصب شده باشه؟

من تازه تازه تازه هستم در اندروید و الان یه پروژه خالی ایجاد کردم ارور داره اصلا تا حالا با اندروید کار نکردم، دارم با آموزش پیش میرم و چون همون اول گیر کردم اصلا جلوتر نرفتم.این کد را کجا اضافه کنم؟من ارور که میده اینه:
Description Resource Path Location Type

The container 'Android Dependencies' references non existing library 'E:\eclipse_projecs\appcompat_v7\bin\appcompat_v7.jar' L Build path Build Path Problem
پاسخ

ایجاد پروژه اندروید در اکلیپس(خیلی فوری 2 ماهه درگیرم)

#15
(۱۳۹۴/۱۲/۲۸, ۰۱:۵۱ ب.ظ)batman1 نوشته: سلام.
جناب،شما برای چه ورژنی از سیستم عامل برنامه ات رو میسازی؟

من اصلا هنوز شروع نکردم!!!!ولی target و compile را میذارمapi22 میخوام برای اندروید 5.1.1 بنویسم.
پاسخ


پرش به انجمن:


کاربران در حال بازدید این موضوع: 1 مهمان

آخرین کلیدهای غیررایگان

شما هم می توانید کلیدهای غیررایگان منتشر کنید (بیشتر بدانید)