انجمن سایت کلیدستان



راهنماییزمان کنونی: ۱۳۹۵/۰۹/۱۹، ۰۴:۰۶ ب.ظ
کاربران در حال بازدید این موضوع: 1 مهمان
نویسنده: cloner
آخرین ارسال: cloner
پاسخ 7
بازدید 1238

رتبه موضوع:
  • 0 رای - 0 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
راهنمایی

راهنمایی

#1
سلام دوستان
من دارم تو اکلیپس کد نویسی میکنم ولی زیر بعضی از کدها خط زیگزاگ قرمز میکشه
میخوام بدونم ایا مشکلی به وجود میاد بعدا؟؟؟
در ضمن چطوری میتونم پنجره زیر رو توی اکلیپس بیارم؟؟(یعنی این پنجره نمایش داده بشه تو برنامه اکلیپس)

عکس :

   
پاسخ

راهنمایی

#2
با سلام 
این ارور یک اطلاعات کدنویسی را می خواد که هنگام نوشتن یک statement یا دستور، یک عملکرد طبیعی هست و فقط هر کجا که این خط زیگزاگ قرمز رو دیدید ، کلید های Ctrl+1 را فشار دهید . سپس پیشنهاد های برنامه اکلیپس برای برطرف شدن این ارور برای شما نمایش داده می شود و یک نکته که این جا حائز اهمیت است اینه که ارور های زرد در برنامه مشکلی بوجود نمی آورند . 
به شما پیشنهاد می کنم که کلید زیر را حتما مشاهده نمایید :

http://www.kelidestan.com/keys/categorie...ategory=19

یاعلی مدد
تلاش بی وقفه ضامن موفقیت در بهترین عرصه هاست .
بهترین ها در نزد خداوند اند و ما به دنبال بهترین هاییم 
پس این علم و کارمان را در جهت رضای خدا به خدمت میگیریم .
اللهم صلی علی محمد و آل محمد و عجل فرجهم

پاسخ
 سپاس شده توسط admin

راهنمایی

#3
اقا جا داره من اینجا از شما دوست عزیز یه تشکر بکنم بابت این وقتی که میزاری و راهنمایی میکنی
خیلی ممنون
یاعلی
پاسخ
 سپاس شده توسط m.ahwazian

راهنمایی

#4
تشکر را باید از ادمین بکنی که همچین سایتی را تهیه کرده . 
تنها راه تشکر از من اینه که برام دعا کنید . 
یا علی مدد 
تلاش بی وقفه ضامن موفقیت در بهترین عرصه هاست .
بهترین ها در نزد خداوند اند و ما به دنبال بهترین هاییم 
پس این علم و کارمان را در جهت رضای خدا به خدمت میگیریم .
اللهم صلی علی محمد و آل محمد و عجل فرجهم

پاسخ
 سپاس شده توسط admin

راهنمایی

#5
بله درسته از ادمین هم تشکر میکنیم
به مشکل دیگه ای بر خوردم
این کدهارو من نوشتم ولی بعد از اجرا کردن کدها برنامه ای که نوشتم تو دستگاه مجازی اندروید پیداش نیست تا اجرا کنم برنامه هارو
میشه بگین چطوری این اررور هارو برطرف کنم؟؟؟
این کدها:

کد پی‌اچ‌پی:
package com.example.mashinhesab;

import android.os.Bundle;
import android.app.Activity;
import android.view.Menu;
import android.view.View;
import android.view.View.OnClickListener;
import android.widget.Button;
import android.widget.EditText;
import android.widget.TextView;

public class 
MainActivity extends Activity {

    @
Override
    
protected void onCreate(Bundle savedInstanceState) {
        
super.onCreate(savedInstanceState);
        
setContentView(R.layout.activity_main);
        
        final 
EditText n1= (EditTextfindViewById(R.id.editText1);
        final 
EditText n2= (EditTextfindViewById(R.id.editText2);
    
        final 
TextView an =  (TextViewfindViewById(R.id.answer);
       
       
Button mosbat =  (ButtonfindViewById(R.id.jam);
       
Button manfi =  (ButtonfindViewById(R.id.kam);
       
Button zarb =  (ButtonfindViewById(R.id.zarb);
       
Button taghsim =  (ButtonfindViewById(R.id.taghsim);
       
       
mosbat.setOnClickListener(new OnClickListener() {
        
        @
Override
        
public void onClick(View arg0) {
    
            
int e1 =Integer.parseInt(n1.getText().toString()) ;
            
int e2 =Integer.parseInt(n2.getText().toString()) ;
            
int e3 e1 e2;
            
an.setText("javab"+e1+"+"+e2+"="+e3);
        }
    });
    
    
    
    
    
    
    }





اینم ارورر ها:

کد پی‌اچ‌پی:
[2014-08-31 14:11:09 MashinHesab] ------------------------------
[
2014-08-31 14:11:09 MashinHesabAndroid Launch!
[
2014-08-31 14:11:09 MashinHesabadb is running normally.
[
2014-08-31 14:11:09 MashinHesabPerforming com.example.mashinhesab.MainActivity activity launch
[2014-08-31 14:11:09 MashinHesabFailed to find an AVD compatible with target 'Android 4.4'.
[
2014-08-31 14:11:10 MashinHesabPerforming com.example.mashinhesab.MainActivity activity launch
[2014-08-31 14:11:13 MashinHesabLaunching a new emulator with Virtual Device 'virtual_device_1'
[2014-08-31 14:11:13 MashinHesab] New emulator foundemulator-5554
[2014-08-31 14:11:13 MashinHesabWaiting for HOME ('android.process.acore'to be launched...
[
2014-08-31 14:11:33 MashinHesabERRORApplication requires API version 8. Device API version is 7 (Android 2.1-update1).
[
2014-08-31 14:11:33 MashinHesabLaunch canceled
پاسخ
 سپاس شده توسط admin

راهنمایی

#6
سلام.
از هر دوتون سپاسگذارم. 
به خطای زیر توجه کنید :

کد:
ERROR: Application requires API version 8. Device API version is 7 (Android 2.1-update1)

تذکر داده شده که نسخه API برای اندروید نصب شده روی گوشی، برابر 7 است، در صورتی که در پروژه اندروید، حداقل مقدار برابر 8 در نظر گرفته شده است.
بنابراین یا باید مشخصات گوشی مجازی را تغییر بدهید یا اینکه حداقل مقدار درج شده در فایل Androidmanifest.xml از پروژه اندروید رو.

البته چون معمولا ممکنه با تعداد زیادی خطا روبرو شوید (چه حالا و چه در آینده، چون خود من هم در ابتدای راه، خیلی با خطا مواجه می شدم)، توصیه من این است که در موتور جستجوی گوگل، ابتدا عبارت android programming را بنویسید و سپس متن مربوط به خطا را بنویسید. سپس با جستجو کردن این عبارت، معمولا نتایجی می آید که با آنها می توانید خطاها را برطرف کنید.

bookbook 
لطفا برای درج کد، از دکمه مخصوص درج کد در ادیتور انجمن استفاده کنید.
در مورد برنامه نویسی، مدیران تنها راهنمایی می کنند و نوشتن برنامه نهایی، به عهده کاربران می باشد (اینجا محلی برای یادگیری است، نه سفارش کدنویسی).
کاربران باید ابتدا خود به خطایابی برنامه بپردازند، نه اینکه به محض دیدن خطا، کدها را در انجمن، copy و paste کرده و از مدیران انتظار بررسی داشته باشند.
پاسخ

راهنمایی

#7
مرسی از راهنماییتون
 
پاسخ
 سپاس شده توسط admin


پرش به انجمن:


کاربران در حال بازدید این موضوع: 1 مهمان

آخرین کلیدهای غیررایگان

شما هم می توانید کلیدهای غیررایگان منتشر کنید (بیشتر بدانید)